Mise à jour vers PHP PHP 5.1.x 5.3 5.6 sur CentOS

plus CMSSites, y compris Avoir le minimum requis pour l'installation d'une version plus récente d' 5.1.x pe . Le tutoriel ci-dessous va vous montrer quelques étapes simples qui peuvent être la version de PHP pour PHP 5.1 5.3.x pe 5.6.

1. Vous devez d'abord arrêter Web Server. (Service httpd)

httpd stop de service

2. Retirer 5.1.x paquets PHP installés sur le serveur.

yum remove php php-*

3. Après avoir reçu la confirmation que les paquets PHP sont supprimées du serveur, accédez à installer des paquets PHP 5.3.

yum installe php53.i386
yum install php53-bcmath.i386
yum installe php53-cli.i386
yum installe php53-common.i386
yum installe php53-dba.i386
yum install php53-devel.i386
yum installe php53-gd.i386
yum install php53-imap.i386
yum installe php53-intl.i386
yum installe php53-ldap.i386
yum install php53-mbstring.i386
yum install php53-mysql.i386
yum install php53-odbc.i386
yum installe php53-pdo.i386
yum install php53-pgsql.i386
yum install php53-process.i386
yum install php53-pspell.i386
yum installe php53-snmp.i386
yum install php53-soap.i386
yum install php53-xml.i386
yum install php53-xmlrpc.i386

Ou plus simplement, installer tous les packages * php53.

* installer php53

4. Démarrez le serveur Web Apache

service httpd start

Forfaits php53-pear, php53-mcrypt, php53-Mhash, php53-PDO, php53-pecl-apc si php53-pecl-memcache 5.6 pas disponible pour CentOS.

Enfin, vérifiez la version PHP5.3 a été installé avec succès. Créer un Php (par exemple info.php.) Qui ont.:

<? Php

phpinfo ();

phpinfo (INFO_MODULES);

?>

Montez les serveurs de fichiers et d'accéder à l'adresse de Firefox, , ou tout autre navigateur. Le résultat devrait être:

php informations

Vous pouvez voir la version de PHP est installé sur un serveur avec la ligne de commande: php-v ou "yum list installé | grep php»(Affiche tous les paquets PHP installé).

yum list installé php

- Mise à niveau / Installation de PHP sur CentOS 5.3 5.6.

Mise à jour vers PHP PHP 5.1.x 5.3 5.6 sur CentOS

A propos de l'auteur

furtif LP

Fondateur et rédacteur infiltration SettingsDate 2006.
Expérience sur les systèmes d'exploitation Linux (en particulier CentOS), Mac OS X, Windows XP> Windows 10 et WordPress (CMS).

Laisser un commentaire