RÉSOUDRE LE PROBLÈME : Votre serveur exécute PHP version 5.1.6 mais WordPress 3.2.1 nécessite au moins 5.2.4.

Avis pour tous est pas bien connu que pour installer ou faire améliorerCPC à une version plus récente de 3.2Il est nécessaire que être installé une version plus récente 5.2.4.

Si le serveur est d'installer une version de PHP plus ancienne que 5.2.4 d'installer la version WordPress 3.2.1apparaîtra erreur / le message: "Votre serveur exécute PHP version 5.1.6 mais WordPress 3.2.1 nécessite au moins 5.2.4" .
Le problème peut être résolu très simplement en mettant à jour PHP, mais avant de le faire quelques petites choses doivent être envisagées. Tout d'abord, mettre à jour hébergement PHP est exclu d'une part. Vous devez avoir accès à la mise à niveau administrator sur serveur (serveur dédié ou VPS). Dans le second, avant la mise à niveau doit être prudent de documenter et que nouvelle version de PHP ne pas donner Erreurs d'autres sites hébergés sur ce serveur.

pour OS est le plus largement utilisé la serveurs Web (Agreart et / WHM) Va vous montrer comment faire mise à niveau vers PHP 5.2.10 sur CentOS 5.x 32 bits.

Mettre à niveau PHP 5.1.x vers 5.2.x sur CentOS 5.x 32 bits

1. Vérifiez quels paquets / modules sont installés PHP (ex. Php-mcrypt) en plus de paquet standard. Le cas échéant, ils seront supprimés ou actuzlizate.

Vérifiez les paquets installés:

rpm -qa | grep php
old_php_version

2. Ajouter de nouvelles archives requis améliorerPHP version acquis.

nano /etc/yum.repos.d/CentOS-Testing.repo

Dans le fichier nouvellement créé (CentOS-Testing.repo) Va ajouter les lignes ci-dessous (copier / coller):

[c5-testing] 
name=CentOS-5 Testing 
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/ 
enabled=1 
gpgcheck=1 
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing 
includepkgs=php*

Ctrl + X pour enregistrer le fichier CentOS-Test.repo.

3. Update PHP via yum :

yum update

4. Restart / httpd :

service httpd restart

après restart httpd vérifiez la version et les packages installés:

new_php_version

Vérifiez les erreurs modules / packages:

php -v

- Mise à niveau PHP / CentOS 32 bits (i386).

Comment l'utiliser ? » Linux » RÉSOUDRE LE PROBLÈME : Votre serveur exécute PHP version 5.1.6 mais WordPress 3.2.1 nécessite au moins 5.2.4.

Fondateur et rédacteur Stealth Settings, de 2006 à nos jours. Expérience sur les systèmes d'exploitation Linux (Surtout CentOS), Mac OS X, Windows XP> Windows 10 si WordPress (CMS).

Laisser un commentaire